PSP oldTimer

USD $99.00 (UK/EU orders incur VAT)

PSP oldTimerME (Master Edition) installer includes two versions of the plug-in: PSP oldTimerME, a vintage-style compressor designed for demanding track and program compression, limiting and mastering processing and PSP oldTimer a vintage-style compressor designed for track or program compression and limiting.

SKU: 1246-1202 Categories: , ,

Description

Summary

These are versatile compressors that offer detailed control and an exceptionally musical sound. PSP oldTimer plug-ins are not based on any specific hardware, rather they are inspired by vintage circuits and were designed to emulate favourite characteristics of such compressors.

PSP oldTimerME version of this compressor combines advanced features such as the option to process left, right, mid or side channel exclusively while being very simple to set up. In the case of PSP oldTimer, the goal was to provide a simple compressor that offers an exceptionally musical sound while requiring a minimum of tweaking. PSP oldTimer is so simple and so easy to use, that it’s difficult to make it sound bad even at extreme settings. These compressors offer soft and smooth compression in most applications, however they may slightly colour the sound with their tube emulation on transients when heavily driven internally by high compression values.

Key Features

  • High quality signal processing algorithms
  • All internal processing done with 64 bit double precision floats
  • Option to process left, right, mid or side channel exclusively (ME version)
  • 32 and 64 bit floating point audio streams supported
  • ZERO samples of latency
  • Up to 192kHz sample rates supported
  • x64 support for Windows and Mac OSX systems
  • Library of presets

System Requirements

MAC Minimum Requirements

  • AudioUnit: Mac OSX 10.5 or later, 32 or 64-bit host application capable of running AudioUnit plug-ins with Cocoa view
  • VST: Mac OSX 10.5 or later, 32 or 64-bit VST 2.4 compatible host application
  • RTAS: Mac OSX 10.4 or later, ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)

PC Minimum Requirements

  • VST: Windows x32 or x64 (XP Service Pack 2, Vista or 7), VST 2.4 compatible application
  • RTAS: Windows x32 or x64 (XP Service Pack 2, Vista or 7), ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)

No refunds are possible on digital products – view our full Refund Policy here.

Select your currency
USD United States (US) dollar